1CLenta.ru  

XDTO - выгрузка загрузка данных

Программирование системы     25.10.2016 10:19     18743

XDTO-пакет - это объект метаданных, который хранит схему данных. Аббревиатура расшифровывается как XML Data Transfer Objects. Схему данных можно описать в xml файле, а затем подгрузить в созданный XDTO-пакет. Для программной работы с пакетами-xdto предназначен объект глобального контекста ФабрикаXDTO.

Текст схемы


<xs:schema xmlns:tns="Выгрузка" xmlns:xs="http://www.w3.org/2001/XMLSchema" targetNamespace="Выгрузка" attributeFormDefault="unqualified" elementFormDefault="qualified">
<xs:complexType name="Список">
<xs:sequence>
<xs:element name="Номенклатура" type="tns:Номенклатура" minOccurs="0" maxOccurs="unbounded"/>
</xs:sequence>
</xs:complexType>
<xs:complexType name="Номенклатура">
<xs:sequence>
<xs:element name="ГУИД" type="xs:string" minOccurs="0"/>
<xs:element name="Наименование" type="xs:string" minOccurs="0"/>
<xs:element name="Код" type="xs:string" minOccurs="0"/>
</xs:sequence>
</xs:complexType>
</xs:schema>

ФабрикаXDTO с использованием XDTO-пакетов


ФабрикаXDTO содержит xml-схемы всех XDTO-пакетов, которые есть в конфигурации, и обладает набором методов для работы с данными. Для того чтобы схема стала доступна в объекте ФабрикаXDTO, её необходимо добавить в дереве метаданных в ветку с названием "XDTO-пакеты". Добавить можно двумя способами, либо загрузить из файла с расширением (*.xsd), либо добавить вручную узлы пакета.

Импорт схемы XML

Редактор схемы XML

Выгрузка данных в XML файл

Если схема хранится в метаданных Общие->XDTO-пакеты, то обращение к ней возможно только на сервере.
&НаСервере
Процедура ВыгрузитьДанные()

//Создание ОбъектаXDTO с типом Список
ТипЗначенияXDTO = ФабрикаXDTO.Тип("Выгрузка", "Список");
СписокXDTO = ФабрикаXDTO.Создать(ТипЗначенияXDTO);

//Создание ОбъектаXDTO с типом Номенклатура
ТипЗначенияXDTO = ФабрикаXDTO.Тип("Выгрузка", "Номенклатура");
НоменклатураXDTO = ФабрикаXDTO.Создать(ТипЗначенияXDTO);

НоменклатураXDTO.ГУИД = "00000000-0000-0000-0000-000000000000";
НоменклатураXDTO.Наименование = "Корзинка";
НоменклатураXDTO.Код = "00000001";

СписокXDTO.Номенклатура.Добавить(НоменклатураXDTO);

//Запись в XML файл
ЗаписьXML = Новый ЗаписьXML;
ПараметрыЗаписиXML = Новый ПараметрыЗаписиXML("UTF-8", "1.0", Ложь);
ЗаписьXML.ОткрытьФайл("C://Выгрузка.xml", ПараметрыЗаписиXML);
ЗаписьXML.ЗаписатьОбъявлениеXML();
ФабрикаXDTO.ЗаписатьXML(ЗаписьXML, СписокXDTO);
ЗаписьXML.Закрыть();

КонецПроцедуры


Загрузка данных из XML файла

Процедура ЗагрузитьДанные()

ЧтениеXML = Новый ЧтениеXML;
ЧтениеXML.ОткрытьФайл("C://Выгрузка.xml");
ТипЗначенияXDTO = ФабрикаXDTO.Тип("Выгрузка", "Список");
ОбъектXDTO = ФабрикаXDTO.ПрочитатьXML(ЧтениеXML, ТипЗначенияXDTO);

Для каждого ЗначениеXDTO Из ОбъектXDTO.Номенклатура Цикл
Сообщить(ЗначениеXDTO.ГУИД);
Сообщить(ЗначениеXDTO.Наименование);
Сообщить(ЗначениеXDTO.Код);
КонецЦикла;

КонецПроцедуры


ФабрикаXDTO с использованием схемы из файла


Создать объект ФабрикаXDTO на основании файла схемы. Для этого существует глобальный метод СоздатьФабрикуXDTO(<Путь>, <Пакеты>). Если работа с ФабрикойXDTO происходит во внешней обработке, то схему можно хранить в макете с типом "Текстовый документ". Но для создания объекта ФабрикиXDTO все равно необходимо чтобы схема лежала во внешнем файле. Для этого можно создать временный файл и поместить в него содержимое макета.

Выгрузка данных в XML файл

Процедура ВыгрузитьДанные()

ФайлСхемы = Новый Файл(КаталогВременныхФайлов() + "Scheme.xsd");
Если ФайлСхемы.Существует() Тогда
УдалитьФайлы(ФайлСхемы.ПолноеИмя);
КонецЕсли;

Макет = Получитьмакет("ТекстовыйДокумент");
Макет.Записать(ФайлСхемы.ПолноеИмя);

НоваяФабрикаXDTO = СоздатьФабрикуXDTO(ФайлСхемы.ПолноеИмя);

//Создание ОбъектаXDTO с типом Список
ТипЗначенияXDTO = НоваяФабрикаXDTO.Тип("Выгрузка", "Список");
СписокXDTO = НоваяФабрикаXDTO.Создать(ТипЗначенияXDTO);

//Создание ОбъектаXDTO с типом Номенклатура
ТипЗначенияXDTO = НоваяФабрикаXDTO.Тип("Выгрузка", "Номенклатура");
НоменклатураXDTO = НоваяФабрикаXDTO.Создать(ТипЗначенияXDTO);

НоменклатураXDTO.ГУИД = "00000000-0000-0000-0000-000000000000";
НоменклатураXDTO.Наименование = "Корзинка";
НоменклатураXDTO.Код = "00000001";

СписокXDTO.Номенклатура.Добавить(НоменклатураXDTO);

//Запись в XML файл
ЗаписьXML = Новый ЗаписьXML;
ПараметрыЗаписиXML = Новый ПараметрыЗаписиXML("UTF-8", "1.0", Ложь);
ЗаписьXML.ОткрытьФайл("C://Выгрузка.xml", ПараметрыЗаписиXML);
ЗаписьXML.ЗаписатьОбъявлениеXML();
НоваяФабрикаXDTO.ЗаписатьXML(ЗаписьXML, СписокXDTO);
ЗаписьXML.Закрыть();

КонецПроцедуры


Загрузка данных из XML файла

Процедура ЗагрузитьДанные()

ФайлСхемы = Новый Файл(КаталогВременныхФайлов() + "Scheme.xsd");
Если ФайлСхемы.Существует() Тогда
УдалитьФайлы(ФайлСхемы.ПолноеИмя);
КонецЕсли;

Макет = Получитьмакет("ТекстовыйДокумент");
Макет.Записать(ФайлСхемы.ПолноеИмя);

НоваяФабрикаXDTO = СоздатьФабрикуXDTO(ФайлСхемы.ПолноеИмя);

ЧтениеXML = Новый ЧтениеXML;
ЧтениеXML.ОткрытьФайл("C://Выгрузка.xml");
ТипЗначенияXDTO = НоваяФабрикаXDTO.Тип("Выгрузка", "Список");
ОбъектXDTO = НоваяФабрикаXDTO.ПрочитатьXML(ЧтениеXML, ТипЗначенияXDTO);

Для каждого ЗначениеXDTO Из ОбъектXDTO.Номенклатура Цикл
Сообщить(ЗначениеXDTO.ГУИД);
Сообщить(ЗначениеXDTO.Наименование);
Сообщить(ЗначениеXDTO.Код);
КонецЦикла;

КонецПроцедуры

Комментарии (1)

1. HaroldVow  29.10.2020 17:30  
Finding the Ideal Match With Hookup Women
Hookup girls will not be all terrible. The best person can discover and day some beautiful females.

Unfortunately, there is absolutely no excellent hookup women in the world. Not all the girls love internet dating. Many of them will not step out with somebody when they usually do not <a href=https://hooksexup.com/features/transgender-icon-jayne-county-banned-from-facebook>https://hooksexup.com/features/transgender-icon-jayne-county-banned-from-facebook</a> feel drawn to them. Some females even would rather stay at home alone with their toddlers.

So, when you wish to identify a excellent girl to get sexual activity with, the most effective way would be to method the proper woman. Once you search for a hookup partner, it's vital that you stay away from taking a look at them as simply a friend or lover. Your romantic relationship has to be depending on sensations for them.

Courting can be so confusing for many people. There is always a great deal of tension to satisfy a girl, get connected, after which get dumped. Just make sure accomplish this, it's like you're seeking to repair the problem by doing nothing.

Courting are often very tough. It's challenging to get that you real "one" woman. Courting with several females can become strenuous. So what's the remedy?

The perfect solution is to find a woman's coronary heart initial, then slowly job towards you from her to her close friends, co-employees, and so forth. Whenever you can get her center, you've acquired an easy chance of obtaining her into bed furniture along.

But where do you go to discover best hookup girls? There is a couple of alternatives. It is possible to go to a nightclub, a group, on the web, online dating message boards, and many others. But be careful, lots of the people you fulfill on these internet websites are committed. Except if you're confident you could trust them, don't proceed.

To discover the right particular person, you must find their coronary heart initial. So just go and get her!

Ladies will almost always be going to be timid, stressed, and frightened of rejection. But in the long run, everything that anxiety is certainly not in comparison to the enjoyable they could have together with you. In case you have an incredible sense of humor and enjoy existence, women will naturally gravitate towards you.

Young girls need to have enjoyable and exhilaration with their lifestyles. If you're having a great time, they'll naturally be surrounding you and stay at ease with you.

Men might be different personas. They might be bashful and tranquil at times, while others are outgoing and amusing.

Hookup females are really hypersensitive and intimate. And many of them can be great associates to share existence with.

More often than not, girls only day other people simply because they require friendship and companionship. They could also simply want to be around somebody who can certainly make their existence much easier. Of course, if you're the main one who's ever present to them, it's effortless to get a date along with them.

With regards to discovering hookup ladies, you don't treatment that you satisfy them or whatever you do, you only need to produce a close friend. Should you do, she'll be yours forever. She might even become your life time friend.

In terms of getting hookup women, look over a chitchat internet site, a forum, and so on. They generally have numerous members who are seeking females. The more men and women you already know, the better it is to get started on discussions and familiarize yourself with one another.

If you're not a great friend, don't rush. Try out somewhat at first. When you're comfy together, after that you can try some online dating.

One more great location to find hookup ladies is by a dating website. The majority of them have sizeable sets of females searching for good friends and days. They are great men and women to talk with because they're open and accessible to new as well as other experiences.

Most men who particular date hookup women get the procedure of dating being enjoyable. And quite often you will find the optimal woman for the time. By using online dating services professional services, you can actually fulfill countless girls to date right away and have plenty of fun.

Для того чтобы добавить сообщение, необходимо Войти или Зарегистрироваться

 
 


Регистрация