1CLenta.ru  

Вывести штрих-код в печатную форму

Программирование системы     22.09.2016 14:12     9357

Для вывода штрих кода в печатную форму, в 1С:Предприятии предназначен объект "1С.V8.Печать штрих-кодов". Для того чтобы он стал доступен на компьютере должна быть установлена компонента "1CBarCode.exe".

Установка компоненты 1CBarCode.exe


Дистрибутив с компонентой для штрих-кодов можно скачать на официальном сайте 1С или на диске ИТС в директории 1CITSEXETradeWare1C1CBarCode. После скачивания потребуется установка.

Запуск установки 1CBarCode.exe



После запуска программа подготовится к установке и предложит продолжить установку.

Запуск установки 1CBarCode

Для продолжения инсталяции программы нужно будет принять условия.

Условия установки 1CBarCode

Затем необходимо выбрать место на жестком диске для установки программы и продолжить установку

Выбор места установки 1CBarCode

Установка займет примерно 10-15 секунд в зависимости от комплектации ПК.

Процесс установки 1CBarCode

При успешном окончании появится окно.

Окончание установки 1CBarCode

Добавление штрих-кода в печатную форму


Во многих типовых конфигурациях уже реализован механизм присвоения штрих-кодов некоторым документам, или справочникам. Если данного функционала нет, то потребуется самостоятельно написать его в конфигурации. В примере ниже демонстрируется вывод произвольного штрих-кода.

Добавление рисунка в макет. Для того чтобы добавить рисунок нужно открыть в главном меню (Таблица)-(Рисунки)-(Вставить объект...).

Добавление рисунка в макет 1С

В окне "Вставка объекта" необходимо выбрать "Элемент управления" и Тип объект: 1С.V8.Печать штрих-кодов.

Элемент управления 1С.V8.Печать штрих-кодов

После добавления рисунка к нему можно обратиться программно чтобы задать "ТипКода" и "ТекстКода". Как правило в типовых конфигурациях типы кодов хранятся в плане видов характеристик с наименованием "ТипыШтрихкодов". В конфигурации могут быть готовые функции для получения значения "ТипКода", например ПолучитьЗначениеТипаШтрихкодаДляЭУ().
Функция ПолучитьЗначениеТипаШтрихкодаДляЭУ(ТипКода)
Перем Значение;

Если ТипКода = ПланыВидовХарактеристик.ТипыШтрихкодов.EAN8 Тогда
Значение = 0;
ИначеЕсли ТипКода = ПланыВидовХарактеристик.ТипыШтрихкодов.EAN13 Тогда
Значение = 1;
ИначеЕсли ТипКода = ПланыВидовХарактеристик.ТипыШтрихкодов.EAN128 Тогда
Значение = 2;
ИначеЕсли ТипКода = ПланыВидовХарактеристик.ТипыШтрихкодов.Code39 Тогда
Значение = 3;
ИначеЕсли ТипКода = ПланыВидовХарактеристик.ТипыШтрихкодов.Code128 Тогда
Значение = 4;
Иначе
Значение = -1;
КонецЕсли;

Возврат Значение;
КонецФункции


Процедура ВывестиШтрихКодВПечатнуюФорму(Кнопка)

//Для типовых конфигураций
ТипКода = ПолучитьЗначениеТипаШтрихкодаДляЭУ(ПланыВидовХарактеристик.ТипыШтрихкодов.EAN8);

//Для произвольных конфигураций
ТипКода = 0; //EAN8
ТипКода = 1; //EAN13
ТипКода = 2; //EAN128
ТипКода = 3; //CODE39
ТипКода = 4; //CODE128
ТипКода = 5; //CODE16K
ТипКода = 6; //PDF417
ТипКода = 7; //Industrial2of5
ТипКода = 8; //Interleaved2of5
ТипКода = 9; //Code39FullASCII
ТипКода = 10; //CODE93
ТипКода = 11; //ITF14
ТипКода = 12; //RSS14
ТипКода = 13; //CodaBar
ТипКода = 14; //EAN13 AddOn 2
ТипКода = 15; //EAN13 AddOn 5

Макет = ПолучитьМакет("Макет1");
Макет.Рисунки.D1.Объект.ТекстКода = "1234567";
Макет.Рисунки.D1.Объект.ТипКода = ТипКода;
Макет.Показать();

КонецПроцедуры

Комментарии (0)

Для того чтобы добавить сообщение, необходимо Войти или Зарегистрироваться

 
 


Регистрация