1CLenta.ru  

ЗаписьXML, ЧтениеXML в 1С:Предприятии

Программирование системы     29.08.2016 11:46     3715

Для работы с XML в 1С предназначены специальные объекты. Существует несколько методов для того, чтобы создавать, парсить XML в 1С:Предприятии. Один из методов - это использовать объекты встроенного языка ЗаписьXML, ЧтениеXML. Если свойств и методов данных объектов недостаточно, то в 1С:Предприятии для работы с XML предназначен "ДокументDOM". Кроме того, благодаря COM технологии, существует возможность создать "Msxml2.DOMDocument".

Записать XML файл


Функция СоздатьXML()

ЗаписьXML = Новый ЗаписьXML;

//Открытие XML файла
ЗаписьXML.ОткрытьФайл("C:\Test.xml");
ЗаписьXML.ЗаписатьОбъявлениеXML();

//Добавить корневой узел
ЗаписьXML.ЗаписатьНачалоЭлемента("RootTag");

//Добавить подчиненный узел
ЗаписьXML.ЗаписатьНачалоЭлемента("Tag");
ЗаписьXML.ЗаписатьАтрибут("ИмяАтрибута","ЗначениеАтрибута");
ЗаписьXML.ЗаписатьТекст("Текст");
ЗаписьXML.ЗаписатьСекциюCDATA("Значение");
ЗаписьXML.ЗаписатьКонецЭлемента();

//Закрыть корневой узел
ЗаписьXML.ЗаписатьКонецЭлемента();

//Если файл не открыт, то метод вернёт XML-строку
СтрокаXML = ЗаписьXML.Закрыть();

КонецФункции


Прочитать XML файл


Функция СчитатьXML()

ЧтениеXML = Новый ЧтениеXML;

//Загрузить XML из строки
ЧтениеXML.УстановитьСтроку("<?xml version=""1.0"" encoding=""UTF-8""?>
|<RootTag>
|<Tag Имя="
"Значение"">Текст<![CDATA[Значение]]</Tag>
|</RootTag>"
);

//Загрузить файл XML
ЧтениеXML.ОткрытьФайл("C:\Test.xml",,,"UTF-8");

//Перебор узлов
Пока ЧтениеXML.Прочитать() Цикл

Если ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда
Если ЧтениеXML.ЛокальноеИмя = "Tag" Тогда
Читаем = Истина;
КонецЕсли;
ИначеЕсли ЧтениеXML.ТипУзла = ТипУзлаXML.Текст Тогда
Если Читаем Тогда
Значение = XMLЗначение(Тип("Строка"), ЧтениеXML.Значение);
Читаем = Ложь;
КонецЕсли;
КонецЕсли;

КонецЦикла;

ЧтениеXML.Закрыть();

КонецФункции


Похожие статьи:
Записать, прочитать XML файл из DomDocument
Запись, чтение XML из ДокументDOM

Комментарии (0)

Для того чтобы добавить сообщение, необходимо Войти или Зарегистрироваться

 
 


Регистрация