1CLenta.ru  

Пауза, задержка времени, при выполнении кода 1С

Программирование системы     30.07.2016 12:18     9061

Задержку времени в 1С можно реализовать с помощью COM объекта "WScript.Shell" или на встроенном языке.

Задержка времени на встроенном языке 1С


На встроенном языке 1С можно написать цикл с проверкой даты и времени. Данный метод является более универсальным.

Процедура ПаузаПустымЦиклом(Секунды)

ВремяОкончания = ТекущаяДата() + Секунды;
Пока ТекущаяДата() <= ВремяОкончания Цикл
КонецЦикла;

КонецПроцедуры


Задержка времени на "WScript.Shell"


Данный объект позволяет выполнять различные сценарии в операционной системе Windows. Недостаток данного подхода - это при выполнении команд открывается консольное окно. Метод Timeout запускает цикл который автоматически будет остановлен через заданное количество секунд.

Процедура TimeoutWScript(Секунды)

WScript = Новый COMОбъект("WScript.Shell");
WScript.Run("timeout /t " + Секунды, 0, Ложь);

КонецПроцедуры

Комментарии (0)

Для того чтобы добавить сообщение, необходимо Войти или Зарегистрироваться

 
 


Регистрация