1CLenta.ru  

Загрузить html страницу в 1С через InternetExplorer

Программирование системы     27.07.2016 14:00     2048

Web страницу в 1С Предприятии можно запросить разными способами. На встроенном языке 1С есть специальные объекты для работы с Интернетом.

Для запроса HTML страницы предназначен объект HTTPСоединение. Данный объект обладает широким набором методов и свойств, благодаря чему можно выполнять сложные запросы страниц через Интернет. С помощью HTTPСоединение отправляются POST и GET запросы.

Благодаря COM технологии есть возможность запрашивать web страницы через сторонние объекты. Одним из популярных, является COM объект WinHTTP.WinHttpRequest. Он позволяет отправлять как POST так и GET запросы.

Кроме всех перечисленных выше способов получить web страницу, так же можно с помощью COM объекта "InternetExplorer.Application". Данный объект принадлежит браузеру InternetExplorer в операционной системе Windows. При работе с InternetExplorer.Application можно программно запрашивать страницы и выполнять различные действия с HTML страницами.

Запрос страницы через InternetExplorer.Application


Процедура ПолучитьСтраницуЧерезIE()

Попытка
IE = Новый COMОбъект("InternetExplorer.Application");
Исключение
ВызватьИсключение "Ошибка создания InternetExplorer.Application";
КонецПопытки;

//Видимость браузера
IE.Visible = Истина;

//Запрос страницы
IE.Navigate("http://1clenta.ru");

//Ожидание загрузки страницы
Пока (IE.readyState < 4) ИЛИ (IE.Busy = -1) Цикл
КонецЦикла;

//Текст страницы с тэгами
InnerHtml = IE.Document.body.innerHtml;

//Текст страницы без тэгов
InnerText = IE.Document.body.innerText;

//Найти HTML элемент по значению атрибута id
Element = IE.document.getElementByID("id");
Element.Value = "";

//Нажать на HTML элемент найденный
IE.document.getElementByID("id-123").click();

//Найти массив HTML элементов по значению атрибута name
ElementArray = IE.document.getElementsByName("test-name");
Для каждого Element Из ElementArray Цикл
Element.Value = "";
КонецЦикла;

//Закрыть браузер
IE.Quit();

КонецПроцедуры

Комментарии (0)

Для того чтобы добавить сообщение, необходимо Войти или Зарегистрироваться

 
 


Регистрация