1CLenta.ru  

Преобразовать ФИО к формату Фамилия И.О.

Программирование системы     26.05.2016 12:33     1934

Для преобразования Фамилии Имени Отчества к формату Фамилия И.О. или к формату И.О. Фамилия, во встроенном языке 1С, функций не предусмотрено. Во многих типовых конфигурациях 1С в общих модулях, можно найти готовые экспортные функции для преобразования ФИО к нужному формату. Такие функции могут называться, например, ФИО(). Используя глобальный поиск в 1С:Конфигураторе можно найти функции для преобразования ФИО.

Форматирование ФИО


Функция возвращает отформатированную строку ФИО. Механизм преобразования реализован средствами встроенного языка программирования. Функция на вход принимает 4 параметра.

Параметры
  • Фамилия - фамилия (строка)
  • Имя - полное имя(строка)
  • Отчество - полное отчество(строка)
  • ИОПередФамилией - определяет с какой стороны от фамилии выводить инициалы (булево)

Функция ПолучитьФИО(Фамилия, Имя, Отчетство, ИОПередФамилией)

Если Не ПустаяСтрока(Имя) Тогда
ИнициалИмени = ВРег(Лев(Имя, 1)) + ".";
КонецЕсли;

Если Не ПустаяСтрока(Отчетство) Тогда
ИнициалОтчетсва = ВРег(Лев(Отчетство, 1)) + ".";
КонецЕсли;

Если ИОПередФамилией Тогда
Результат = ИнициалИмени + ИнициалОтчетсва + " " + Фамилия;
Иначе
Результат = Фамилия + " " + ИнициалИмени + ИнициалОтчетсва;
КонецЕсли;

Возврат Результат;

КонецФункции

Комментарии (0)

Для того чтобы добавить сообщение, необходимо Войти или Зарегистрироваться

 
 


Регистрация