1CLenta.ru  

Отключение и включение защиты от опасных действий

Настройка системы     20.11.2018 10:21     116

В новой версии платформы 8.3.9 реализована защита от потенциально опасных действий пользователя. При выполнении потенциально опасных действий, появляется сообщение в котором содержится предупреждение. В этом сообщении система предлагает пользователю решить, продолжить выполнение данного действия или отказаться. Если продолжить выполнение действия, то данное решение система запомнит и при следующем выполнении, этого же действия, предупреждение показываться не будет. Вместе с разрешением на выполнение данного действия система запоминает хеш объекта. Поэтому если изменить, например, обработку, то при открытии для нее снова начнет выводится предупреждение.

Список потенциально опасных действий:
- Загрузка внешнего отчета, обработки или расширения конфигурации.
- Загрузка или обновление конфигурации/расширения.
- Доступ из внешнего отчета/обработки или расширения к следующим возможностям: исполнение команды операционной системы, управление пользователями, загрузка внешней компоненты.

При открытии внешних обработок через главное меню Файл->Открыть, появляется предупреждение:

Предупреждение безопасности
Открывается "Внешняяобработка1" из файла "C:\ВнешняяОбработка1.epf".
Рекомендуется обращать внимание на источник, из которого был получен данный файл. если с источником нет
договоренности о разработке дополнительных модулей, или есть сомнения в содержимом файла, то его не рекомендуется
открывать, поскольку это может нанести вред компьютеру и данным.
Разрешить открывать данный файл?


Предупреждение безопасности 1с

Отключение защиты от опасных действий через конфигуратор


Для управление защитой от опасных действий необходимо открыть конфигуратор. В главном меню нужно перейти Администрирование->Пользователи. Выбрать пользователя и отключить или включить флажок "Защита от опасных действий".

Флажок защита от опасных действий

Программное отключение защиты от опасных действий


Для программного включения или отключения защиты от опасных действий реализованы специальные свойства объектов.

//Пользователь информационной базы
&НаСервере
Процедура КомандаНаСервере()
Пользователь = ПользователиИнформационнойБазы.ТекущийПользователь();
Пользователь.ЗащитаОтОпасныхДействий.ПредупреждатьОбОпасныхДействиях = Ложь;
Пользователь.Записать();
КонецПроцедуры


//Расширение конфигурации
&НаСервере
Процедура КомандаНаСервере()
Отбор = Новый Структура;
Отбор.Вставить("Имя", "Расширение1");
МассивРасш = РасширенияКонфигурации.Получить(Отбор);
Расширение = МассивРасш[0];
Расширение.ЗащитаОтОпасныхДействий.ПредупреждатьОбОпасныхДействиях = Ложь;
Расширение.Записать();
КонецПроцедуры


//Подключение внешней обработки
&НаКлиенте
Процедура Команда(Команда)
КомандаНаСервере();
ОткрытьФорму("ВнешняяОбработка.ВнешняяОбработка1.Форма");
КонецПроцедуры

&НаСервере

Процедура КомандаНаСервере()
ОписаниеЗащиты = Новый ОписаниеЗащитыОтОпасныхДействий;
ОписаниеЗащиты.ПредупреждатьОбОпасныхДействиях = Ложь;
Обработка = ВнешниеОбработки.Создать("C:\ВнешняяОбработка1.epf",,ОписаниеЗащиты);
КонецПроцедуры

Комментарии (0)

Для того чтобы добавить сообщение, необходимо Войти или Зарегистрироваться

 
 


Регистрация