1CLenta.ru  

Программное добавление, удаление пользователей 1С

Программирование системы     06.09.2018 08:28     417

Доступ пользователей к информационной базе 1С, осуществляется при помощи авторизации. Для каждого работника создается объект пользователь, под которым осуществляется вход и работа в системе. Поэтому, для того чтобы работник мог войти в базу, ему необходимо знать логин и пароль. Редактирование логина, пароля и другой информации о пользователе доступно в 1С конфигураторе, а в типовых конфигурациях можно настраивать и в 1С предприятии. Таким образом, добавление, удаление, редактирование и настройка пользователей осуществляется через интерфейс программы 1С. Все эти действия могут быть выполнены программно, с помощью средств встроенного языка 1С.

Программный доступ к пользователям


Во встроенном языке программирования, предусмотрены специальные объекты для добавления, редактирования и удаления пользователей системы. Работа с пользователями осуществляется через свойство глобального контекста ПользователиИнформационнойБазы.

Процедура ДобавитьПользователяИБ()

Пользователь = ПользователиИнформационнойБазы.СоздатьПользователя();
Пользователь.Имя = "Администратор";
Пользователь.Пароль = "12345";
Пользователь.ПоказыватьВСпискеВыбора = Истина;
Пользователь.Роли.Добавить(Метаданные.Роли.АдминистраторСистемы);
Пользователь.ОсновнойИнтерфейс = Метаданные.Интерфейсы.Общий;
Пользователь.Записать();

КонецПроцедуры


Процедура УдалитьПользователяИБ()

Пользователь = ПользователиИнформационнойБазы.НайтиПоИмени("Администратор");
Пользователь.Удалить();

Пользователь = ПользователиИнформационнойБазы.ТекущийПользователь();
Пользователь.Удалить();

КонецПроцедуры


Процедура ВывестиПользователейИБ()

Список = ПользователиИнформационнойБазы.ПолучитьПользователей();

Для каждого Пользователь Из Список Цикл
Сообщить(Пользователь);
КонецЦикла;

КонецПроцедуры

Комментарии (0)

Для того чтобы добавить сообщение, необходимо Войти или Зарегистрироваться

 
 


Регистрация