1CLenta.ru  

Рисунок в табличном документе растягивается по высоте строк

Программирование системы     08.05.2016 13:30     1732

При создании макета на основе "ТабличногоДокумента", для добавления доступны различные графические элементы(овал, прямая, прямоугольник, текст, картинка, и многие другие). Например, в табличный документ можно добавить рисунок с типом текст. Данный элемент автоматически привязывается к высоте строк. При изменении высоты строк, высота рисунка соответственно уменьшается или увеличивается.

Например если в одной и той же строке находится параметр(размещение текста: переносить) и рисунок типа текст, то в зависимости от содержимого параметра, высота строки и рисунка будет изменяться.

Макет в 1С:Конфигураторе


Макет в конфигураторе

Заполненный макет в 1С:Предприятии


Макет в 1С:Предприятии

Заполненный макет в 1С:Предприятии с восстановленным размером рисунка


Макет в 1С:Предприятии

Чтобы сохранить первоначальные размеры рисунка, необходимо после заполнения табличного документа, установить рисунку первоначальный размер. Первоначальный размер можно взять из макета.

Процедура заполнения и вывода макета


Перем ТабДокумент;
Перем Макет;

Процедура ЗаполнитьИВывестиМакет()

ТабДокумент = Новый ТабличныйДокумент();
Макет = ПолучитьМакет("Макет");
Макет.Параметры.ПараметрТекст = "Длинный текст Длинный текст Длинный текст
|Длинный текст Длинный текст Длинный текст
|Длинный текст Длинный текст Длинный текст"
;
ТабДокумент.Вывести(Макет);
ВосстановитьРазмерыРисунков();
ТабДокумент.Показать();

КонецПроцедуры


Процедура восстановления размеров рисунков


Процедура ВосстановитьРазмерыРисунков()

Для каждого Рисунок Из Макет.Рисунки Цикл
ТабДокумент.Рисунки[Рисунок.Имя].Высота = Рисунок.Высота;
ТабДокумент.Рисунки[Рисунок.Имя].Лево = Рисунок.Лево;
ТабДокумент.Рисунки[Рисунок.Имя].Верх = Рисунок.Верх;
КонецЦикла;

КонецПроцедуры


При добавлении в табличный документ рисунки могут автоматически переименовываться. Это сделано для того чтобы не повторялись имена рисунков при заполнении табличного документа из разных макетов. Чтобы избежать автоматического переименования, необходимо заменить автоматические имена рисунков в макете "D1,D2,...Dn" на любые другие.

Комментарии (0)

Для того чтобы добавить сообщение, необходимо Войти или Зарегистрироваться

 
 


Регистрация