1CLenta.ru  

Программно открыть вариант отчета для управляемого приложения

Программирование системы     12.02.2018 16:01     460

В режиме 1С:Предприятия можно сохранять и загружать настройки отчетов. В управляемом приложении настройки хранятся в хранилище настроек информационной базы (ХранилищеВариантовОтчетов), при необходимости они могут выгружаться во внешние файлы и загружаться из них. Данные настройки называются варианты отчетов. Если нужно настроить один и тот же отчет в разных информационных базах, то достаточно создать настройки на одном компьютере, выгрузить их в файл, а затем загрузить в другой информационной базе.

Программное открытие варианта отчета


К настройкам отчета можно обращаться программно. Если отчет внешний, то сначала его нужно подключить.

&НаСервере
Функция ПодключитьВнешнийОтчет()

ОтчетСсылка = Справочники.ДополнительныеОтчетыИОбработки.НайтиПоНаименованию("Отчет");
Если ОтчетСсылка.Пустая() Тогда
Сообщить("Не удалось найти внешний отчет");
Возврат Ложь;
КонецЕсли;

ДвоичныеДанные = ОтчетСсылка.ХранилищеОбработки.Получить();
АдресХранилища = ПоместитьВоВременноеХранилище(ДвоичныеДанные);
ВнешниеОтчеты.Подключить(АдресХранилища, "Отчет");

Возврат Истина;

КонецФункции


&НаСервере

Функция ПолучитьКлючВариантаОтчета()

СписокВариантов = ХранилищеВариантовОтчетов.ПолучитьСписок("ВнешнийОтчет.Отчет");
Если СписокВариантов.Количество() = 0 Тогда
Возврат Неопределено;
КонецЕсли;

Возврат СписокВариантов[0].Значение;

КонецФункции


&НаКлиенте

Процедура Команда1(Команда)

//Подключение нужно только для внешнего отчета
Если ПодключитьВнешнийОтчет() Тогда

КлючВарианта = ПолучитьКлючВариантаОтчета();
ПараметрыФормы = Новый Структура("КлючВарианта", КлючВарианта);
ОткрытьФорму("ВнешнийОтчет.Отчет.Форма", ПараметрыФормы);

КонецЕсли;

КонецПроцедуры

Комментарии (0)

Для того чтобы добавить сообщение, необходимо Войти или Зарегистрироваться

 
 


Регистрация