1CLenta.ru  

Удаление лидирующих нулей из строки

Программирование системы     07.12.2017 13:52     397

Функция удаления лидирующих нулей обходит символы строки с лева на право, до тех пор пока не встретится символ отличный от нуля. Как только встречается символ не равный нулю, берется часть строки начиная с этого символа и до конца строки. Если входящая строка "000016", функция вернет "16".

Функция УдалитьЛидирующиеНули(Номер)

Для Индекс = 1 По СтрДлина(Номер) Цикл

Если Сред(Номер, Индекс, 1) <> "0" Тогда
Возврат Сред(Номер, Индекс);
КонецЕсли;

КонецЦикла;

//Если все нули
Возврат "";

КонецФункции

Комментарии (0)

Для того чтобы добавить сообщение, необходимо Войти или Зарегистрироваться

 
 


Регистрация