1CLenta.ru  

Директивы компиляции и инструкции препроцессора

Программирование системы     24.03.2017 11:49     1083

Эти конструкции предназначены для явного указания того, где должен выполняться программный код. Для этого во встроенном языке 1с существуют специальные конструкции.

Директивы компиляции


Это новшество реализовано только в управляемом приложении. Использование директив в обычном приложении недоступно. В обычном приложении нет разделения программирования для клиента и сервера. В управляемом приложении перед функциями, процедурами и глобальными переменными можно явно указать где выполнять код (на сервере или на клиенте).

&НаКлиенте - определяет клиентскую процедуру (функцию).
&НаСервере - определяет серверную процедуру (функцию) с контекстом.
&НаСервереБезКонтекста - определяет серверную процедуру (функцию) без контекста.
&НаКлиентеНаСервереБезКонтекста - определяет процедуру (функцию), исполняемую в модуле формы на клиенте и на сервере.
&НаКлиентеНаСервере - определяет процедуру (функцию), исполняемую в модуле команды, выполняемую на клиенте и на сервере.
Без контекста - это означает без доступа к данным формы.

Инструкции препроцессора


Инструкции могут задаваться для процедур (функций) целиком или для отдельных участков программного кода.

Русский Английский
#Если #If
#Тогда #Then
#ИначеЕсли #ElsIf
#Иначе #Else
#КонецЕсли #EndIf
#Область #Region
#КонецОбласти #EndRegion
Клиент (для совместимости) Client
НаКлиенте AtClient
Сервер (для совместимости) Server
НаСервере AtServer
МобильноеПриложениеКлиент MobileAppClient
МобильноеПриложениеСервер MobileAppServer
ТолстыйКлиентОбычноеПриложение ThickClientOrdinaryApplication
ТолстыйКлиентУправляемоеПриложение ThickClientManagedApplication
ВнешнееСоединение ExternalConnection
ТонкийКлиент ThinClient
ВебКлиент WebClient
И AND
ИЛИ OR
НЕ NOT


Примеры

#Если НаСервере Тогда
#КонецЕсли

#Если НаКлиенте Тогда
#КонецЕсли

#Область [<Имя области>]
#КонецОбласти

Комментарии (0)

Для того чтобы добавить сообщение, необходимо Войти или Зарегистрироваться

 
 


Регистрация