1CLenta.ru  

Как получить ip в 1С

Программирование системы     20.03.2017 09:44     1269

С использованием COM объектов можно определить ip адрес компьютера на котором запущено 1С:Предприятие. Определить ip можно с помощью нескольких COM объектов. В примерах ниже используются "WbemScripting.SWbemLocator" и "winmgmts".

Получить ip адреса через "WbemScripting.SWbemLocator"


Процедура ОпределитьIp() 

COMОбъект = ПолучитьCOMОбъект("winmgmts:\\.\root\CIMV2");

Результат = COMОбъект.ExecQuery("SELECT * FROM
|Win32_NetworkAdapterConfiguration
|WHERE IPEnabled = TRUE"
);

Для каждого Строка Из Результат Цикл

Для каждого ПодСтрока Из Строка.IPAddress Цикл
Сообщить(ПодСтрока);
КонецЦикла;

КонецЦикла;

КонецПроцедуры

Определение ip адреса через "winmgmts"


Процедура ОпределитьIp() 

COMОбъект1 = Новый COMОбъект("WbemScripting.SWbemLocator");
COMОбъект2 = COMОбъект1.ConnectServer(".","root\CIMV2");

Результат = COMОбъект2.ExecQuery("SELECT IPAddress FROM
|Win32_NetworkAdapterConfiguration
|WHERE IPEnabled = TRUE"
);

Для каждого Строка Из Результат Цикл
Для каждого ПодСтрока Из Строка.IPAddress Цикл
Сообщить(ПодСтрока);
КонецЦикла;
КонецЦикла;

КонецПроцедуры

Комментарии (0)

Для того чтобы добавить сообщение, необходимо Войти или Зарегистрироваться

 
 


Регистрация