1CLenta.ru  

Определить возраст по дате рождения

Программирование системы     12.02.2017 09:21     637

Для печатных форм или документов может потребоваться расчет возраста по дате рождения. Данный алгоритм можно реализовать стандартными средствами языка программирования.

Функция позволяет рассчитать сколько полных лет прошло с даты рождения.

Функция ВычислитьВозраст()

Возраст = Год(Текущаядата()) - Год(ДатаРождения);

ДеньТекущий = День(Текущаядата());
МесяцТекущий = Месяц(ТекущаяДата());

ДеньРождения = День(ДатаРождения);
МесяцРождения = Месяц(ДатаРождения);

Если МесяцРождения < МесяцТекущий ИЛИ (МесяцРождения = МесяцТекущий И ДеньРождения > ДеньТекущий) Тогда

Возраст = Возраст - 1;

КонецЕсли;

Возврат Возраст;

КонецФункции


Эта функция выводит возраст прописью.
Функция ВозрастПрописью(Возраст)

Параметры = "год, года, лет, м,,,,,0";
Пропись = ЧислоПрописью(Возраст,, Параметры);
Возврат Пропись;

КонецФункции

Комментарии (0)

Для того чтобы добавить сообщение, необходимо Войти или Зарегистрироваться

 
 


Регистрация