1CLenta.ru  

Поиск адреса через Google API

Настройка системы     07.01.2017 11:51     647

Google Places API Web Service предоставляет множество различных сервисов. Для работы с данным сервисом необходима регистрация и создание ключа API. Данный сервис позволяет искать адреса по ключевым словам. Для работы с Google API на компьютере должен быть доступ к интернету.

В Google Places API Web Service установлены лимиты для запросов. Для базовых аккаунтов установлено ограничение на 1000 запросов в сутки. Кроме того может быть установлен допустимый интервал между запросами, например в 30 секунд. Лимиты могут быть увеличены. Подробнее об условиях использования можно узнать по этой ссылке.


Функция ПодборАдреса(ИскомыйТекст, КлючAPI)

Адрес = "/maps/api/place/autocomplete/json?types=address&language=ru";
Адрес = Адрес + "&input=" + ИскомыйТекст + "&key=" + КлючAPI;

OpenSSL = Новый ЗащищенноеСоединениеOpenSSL;
HTTP = Новый HTTPСоединение("maps.googleapis.com",,,,,,OpenSSL);

ЗаголовокHTTP = Новый Соответствие();
ЗаголовокHTTP.Вставить("Host", HTTP.Сервер);

ОтветСервера = HTTP.Получить(Новый HTTPЗапрос(Адрес),, ЗаголовокHTTP);
ТекстСтраницы = ОтветСервера.ПолучитьТелоКакСтроку();

ЧтениеJSON = Новый ЧтениеJSON;
ЧтениеJSON.УстановитьСтроку(ТекстСтраницы);
РезультатJSON = ПрочитатьJSON(ЧтениеJSON);

Если РезультатJSON.status <> "OK" Тогда
ВызватьИсключение РезультатJSON.error_message;
КонецЕсли;

СписокАдресов = Новый СписокЗначений;

Для Каждого Адрес ИЗ РезультатJSON.predictions Цикл
СписокАдресов.Добавить(Адрес.description);
КонецЦикла;

Возврат СписокАдресов;

КонецФункции

Комментарии (0)

Для того чтобы добавить сообщение, необходимо Войти или Зарегистрироваться

 
 


Регистрация