1CLenta.ru  

Запись и чтение текстового файла

Программирование системы     02.01.2017 10:00     449

В 1С:Предприятии текстовый файл можно создать из меню: Файл->Новый->Текстовый документ. Для программной обработки текстовых файлов предназначен объекты "ЧтениеТекста" и "ЗаписьТекста". Данные объекты позволяют считывать, записывать и выполнять другие действия с содержимым текстовых файлов.

Запись в текстовый файл


Для записи текста с использованием объекта "ЗаписьТекста" применяются методы ЗаписатьСтроку() и Записать(). Отличие двух методов в том, что при использовании ЗаписатьСтроку() после записанной строки добавляется переход строки, а при Записать() не добавляется.

Процедура ЗаписьВТекстовыйФайл()

Текст = Новый ЗаписьТекста("C:\файл.txt", КодировкаТекста.UTF8);

//После строки не добавляется переход
Текст.Записать("Строка1");

//После строки добавляется переход
Текст.ЗаписатьСтроку("Строка2");

Текст.Закрыть();

КонецПроцедуры

Чтение текстового файла


Для чтения текста с использованием объекта "ЧтениеТекста" применяются методы Прочитать() и ПрочитатьСтроку(). Отличие двух методов в том, что при использовании ПрочитатьСтроку() возвращается одна строка, а при Прочитать() возвращается все содержимое текстового файла.

Процедура ЧтениеИзТекстовогоФайла()

Текст = Новый ЧтениеТекста("C:\файл.txt", КодировкаТекста.UTF8);

//Чтение всего текста
Строка = Текст.Прочитать();

//Построчное чтение файла
Стр = Текст.ПрочитатьСтроку();
Пока Стр <> Неопределено Цикл
Сообщить(Стр);
Стр = Текст.ПрочитатьСтроку();
КонецЦикла;

Текст.Закрыть();

КонецПроцедуры

Комментарии (0)

Для того чтобы добавить сообщение, необходимо Войти или Зарегистрироваться

 
 


Регистрация