1CLenta.ru  

Обратный перебор массива

Программирование системы     15.12.2016 13:53     2074

Обычно при решении задач по программированию требуется перебирать массив начиная с первого элемента. Иногда может потребоваться перебрать массив в обратном порядке. На встроенном языке программирования 1С:Предприятия можно написать алгоритмы для перебора массива начиная с последнего элемента. Ниже представлены варианты того, как это можно реализвать.

Вариант 1


Процедура ОбратныйПереборМассива1()

Массив = Новый Массив;
Массив.Добавить("один");
Массив.Добавить("два");
Массив.Добавить("три");

Индекс = Массив.ВГраница();
Пока Индекс >= 0 Цикл

Значение = Массив[Индекс];
Индекс = Индекс - 1;

КонецЦикла;

КонецПроцедуры

Вариант 2


Процедура ОбратныйПереборМассива2()

Массив = Новый Массив;
Массив.Добавить("один");
Массив.Добавить("два");
Массив.Добавить("три");

ИндексПоследнего = Массив.ВГраница();

Для Индекс = -ИндексПоследнего По 0 Цикл
Значение = Массив[-Индекс];
КонецЦикла;

КонецПроцедуры

Комментарии (0)

Для того чтобы добавить сообщение, необходимо Войти или Зарегистрироваться

 
 


Регистрация